Форум TRACE MODE: техническая поддержка   
мой профиль / my profile авторизация / login | регистрация / register | поиск / search | часто задаваемые вопросы / faq | начало / forum home

  Следующая старая тема / next oldest topic   Следующая новая тема / next newest topic
» Форум TRACE MODE: техническая поддержка » ТЕХНИЧЕСКАЯ ПОДДЕРЖКА / TECHNICAL SUPPORT TRACE MODE 5 » Драйверы / Device Drivers » мультипорт

   
Автор / Author Тема / Topic: мультипорт
VICTOR S
Forum Haunter / Завсегдатай форума
Участник № / Member № 766


Icon 5 отправлено / posted      Профиль для / Profile for VICTOR S           Редактировать/удалить сообщение / Edit/Delete Post 
Помогите разобраться, пожалуйста. Для подключения семи ЛОМИКОНТОВ 110 используется мультипорт KRON-ISA (реализуется подключение по COM5 - COM11). Установка и диагностика портов в WIN2000 и тестами происходит корректно.
Как только в проекте в параметрах узла производится попытка подключить 6-й и 7-й Ломиконт по СОМ10,СОМ11 сервер матобработки выдает ошибку 40 (ошибка последовательных портов).

Сообщения / Posts 111 | Из / From: РОССИЯ  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 13 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Есть такая особенность - с СОМ-портами ТМ работает через API Windows, так вот это самое API почему-то не инициализирует СОМ-порты с двузначным индексом! [duno / незнайка]
Тут уже ничего поделать нельзя - либо писать свой драйвер с собственными функциями работы с СОМ-портом, либо не выходить за 10-ку.

Может кому из пользователей удалось эту проблему решить?

Сообщения / Posts 15203 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
ksv
Junior Member / Новичок
Участник № / Member № 147


Icon 1 отправлено / posted      Профиль для / Profile for ksv           Редактировать/удалить сообщение / Edit/Delete Post 
Попробуйте в поле номер порта поставить A для 10 СОМа.Для драйвера Ремиконт-130 помогло.
Сообщения / Posts 8 | Из / From: Россия  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 2 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Действительно - номера СОМ-портов в настройках каналов СВЯЗЬ, DCS, MODBUS и КОНТР_1 задаются в формате HEX. Это первое, а во-вторых - в последних релизах ТМ5 были внесены особенности работы API-функций MS Windows с СОМ-портами с двухзначными значениями. Так что - с 5.12 уже точно должно работать.
Сообщения / Posts 15203 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
VICTOR S
Forum Haunter / Завсегдатай форума
Участник № / Member № 766


Icon 1 отправлено / posted      Профиль для / Profile for VICTOR S           Редактировать/удалить сообщение / Edit/Delete Post 
Вынужден вернуться к этому вопросу!До этого проблему решал не выходя за десятку СОМ-портов, но теперь необходимо подключить 10 СОМ. Ситуация таже - ошибка 40. Установка номера порта А для 10 СОМа ничего не дала. Релиз ТМ 5.16. Может есть еще рекомендации?
Сообщения / Posts 111 | Из / From: РОССИЯ  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
У производителя обновление драйверов для этой платы смотрели?
Сообщения / Posts 15203 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
VICTOR S
Forum Haunter / Завсегдатай форума
Участник № / Member № 766


Icon 1 отправлено / posted      Профиль для / Profile for VICTOR S           Редактировать/удалить сообщение / Edit/Delete Post 
Это только что преобретенная нами плата того же производителя только не ISA, а PCI. Под Windows стала очень гладко и по тестам на "заглушку" все отлично. А с ТМ по СОМ проблема осталась....
Сообщения / Posts 111 | Из / From: РОССИЯ  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
У Вас случайно ПК с WinXP нет свободного, на котором эту плату с ТМ можно было бы проверить?
У меня у самого стоит мультипортовая МОХА на 8 портов, у которой 10 и 11-й порты стоят в системе, однако ТМ с ними работает нормально (проверял и на 5.12 и на последнем 5.15+SP1), но у меня стоит WinXP.

Сообщения / Posts 15203 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
VICTOR S
Forum Haunter / Завсегдатай форума
Участник № / Member № 766


Icon 1 отправлено / posted      Профиль для / Profile for VICTOR S           Редактировать/удалить сообщение / Edit/Delete Post 
Установил плату и ТМ под ХР. Запустил проект. Действительно, проект запустился, исчезла ошибка 40. На проверку качества обмена данными нужно время, но, видимо, должно работать. Но очень хотелось знать решение все таки для win2000. Проект год промолотил без замечаний, все надежно. И не хочется производить таких координальных изменений как переход на другую операционку из-за добавления всего одного Ломиконта.
Сообщения / Posts 111 | Из / From: РОССИЯ  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Боюсь, что мы на это повлиять не можем в силу того, что проблема эта в самом драйвере устройтва или в ОС - ведь ТМ просто вызывает стандартную функцию API операционной системы и ничего более.
Сообщения / Posts 15203 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Kate
Junior Member / Новичок
Участник № / Member № 1801


Icon 1 отправлено / posted      Профиль для / Profile for Kate           Редактировать/удалить сообщение / Edit/Delete Post 
И вновь проблема при работе с СОМ-портом с двузначным индексом. TM версия 6.02.1. Работаю с портом, эмулированном преобразователем ADAM-4570. Если назначаю порт с однозначным индексом, то все нормально, а с двузначным индексом - ошибка ERR_RS:COM11 Win32 BuildCommDCB error (87). Хотя какое отношение эта функция имеет к номеру COM-порта - не понятно. Другие программы с этим же COM-портом работают нормально. Из предыдущих постов я так и не поняла, каким образом была решена эта проблема. 06-05-2004 пишете "не выходить за 10-ку", а 07-05-2004 - "в последних релизах ТМ5 были внесены особенности работы API-функций MS Windows с СОМ-портами с двухзначными значениями". Я сталкивалась с этой проблемой при написании драйверов. Оказалось все просто - в CreateFile имя COM-порта надо писать вот так '\\.\COM11'.
Сообщения / Posts 8 | Из / From: Россия  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Дело в том, что прописывать имя порта с CreateFile,как Вы указываете - есть ошибка, которая исправляется путем исправления драйвера порта. МОХА, например, в свое время в своих драйверах эту ошибку и справила. Думаю - есть смысл обратиться по данной проблеме к производителю преобразователя ADAM-4570. Чем вносить эти временные "особенности" в код ТМ.
Сообщения / Posts 15203 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Kate
Junior Member / Новичок
Участник № / Member № 1801


Icon 1 отправлено / posted      Профиль для / Profile for Kate           Редактировать/удалить сообщение / Edit/Delete Post 
Что-то я не поняла, что Вы понимаете под временными "особенностями". Такой синтаксис CreateFile определен Microsoft (http://msdn.microsoft.com/library/default.asp?url=/library/en-us/fileio/fs/createfile.asp), и если в TM это не учтено, то надо исправить, а не отсылать к производителю ADAM-4570. Ведь именно TM вызывает эту функцию, а не драйвер порта. Еще раз повторяю, что другие программы работают с эмулированным COM-портом абсолютно корректно, независимо от того, однозначный у него индекс или двузначный. Также хотелось бы увидеть комментарий по поводу ошибки ERR_RS:COM11 Win32 BuildCommDCB error (87).
Сообщения / Posts 8 | Из / From: Россия  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Еще раз проверил работу ТМ с двухзначными СОМ-портами, релиз 6.03.1 - все инициализируется и работает. (WinXP, MOXA CP168H на 8 портов, проверял СОМ10). Попробуйте последние драйвера от производителя. У меня тоже с данной МОХА были похожие проблемы.
Ошибку BuildCommDCB error (87) выдает API Win32-функция драйвера оборудования. Это ошибка в структуре CommDCB настроек порта - очевидно, как раз драйвер не может принять имя порта для инициализации.

Сообщения / Posts 15203 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
   

   Закрыть тему / Close Topic   Feature Topic   Переместить топик / Move Topic   Удалить топик / Delete Topic Следующая старая тема / next oldest topic   Следующая новая тема / next newest topic
 - Printer-friendly view of this topic
Перейти к / Hop To


Новости АСУ ТП / News | SCADA / HMI | Обучение / Trainings | Свяжитесь с нами / Contact Us

Rambler's Top100 Rambler's Top100



Powered by Infopop Corporation
UBB.classic™ 6.7.2