Форум TRACE MODE: техническая поддержка
Тема закрыта / Topic Closed  Тема закрыта / Topic Closed
Послать новую тему / Post New Topic  
Тема закрыта / Topic Closed  Тема закрыта / Topic Closed
мой профиль / my profile авторизация / login | регистрация / register | поиск / search | часто задаваемые вопросы / faq | начало / forum home

  Следующая старая тема / next oldest topic   Следующая новая тема / next newest topic
» Форум TRACE MODE: техническая поддержка » Пользователи для пользователей » Пользователи для пользователей » Управление дискретными выходами ПР114 (Owen)

   
Автор / Author Тема / Topic: Управление дискретными выходами ПР114 (Owen)
sa104
Forum Member / Участник форума
Участник № / Member № 5825


Icon 1 отправлено / posted      Профиль для / Profile for sa104           Редактировать/удалить сообщение / Edit/Delete Post 
Доброго времени суток всем.
Кому не жалко времени - помогите советом.

Суть следующая:
В Trace Mode 6 создал проект для связи с ПР114 (Овен) по протоколу Modbus
Без проблем получается читать из прибора сетевые переменные.

Но никак не получается управлять дискретными выходами при помощи компонента - выключатель. Адресация вроде правильная, во всяком случае из Simple Scada все управляется. Может у кого есть опыт работы с приборами Овен - буду признателен за помощь.

Сообщения / Posts 43 | Из / From: Россия  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Вы создали канал OUT, залинкованный на Modbus-источник W_word?
При Ваших попытках послать значение в прибор этот канал изменяет свое значение?
Через окно "Просмотр компонентов" посмотрите, что показывает атрибут 4 (Достоверность).

Сообщения / Posts 15121 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
sa104
Forum Member / Участник форума
Участник № / Member № 5825


Icon 1 отправлено / posted      Профиль для / Profile for sa104           Редактировать/удалить сообщение / Edit/Delete Post 
Атрибут 4 показывает _T I, у работающих каналов также. Сейчас пока ухожу, если можно, завтра с утра продолжим?
Сообщения / Posts 43 | Из / From: Россия  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
По каким адресам и какими функциями Modbus Вы пытаетесь писать?
Сообщения / Posts 15121 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
sa104
Forum Member / Участник форума
Участник № / Member № 5825


Icon 1 отправлено / posted      Профиль для / Profile for sa104           Редактировать/удалить сообщение / Edit/Delete Post 
Доброе утро, дали работающий пример.
Там функцией 06 происходит запись в сетевую переменную 0х200 . У меня такие же настройки канала и источника, как в этом примере, но в профайлере вижу, что записывать почему-то пытается функцией 03. На практике это выглядит так - щелкаю мышкой по выключателю на экране, он включается и через полсекунды обратно выключается. Где можно изменить функции Modbus?

Сообщения / Posts 43 | Из / From: Россия  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
sa104
Forum Member / Участник форума
Участник № / Member № 5825


Icon 1 отправлено / posted      Профиль для / Profile for sa104           Редактировать/удалить сообщение / Edit/Delete Post 
Немного поторопился насчет работающего примера - работает только наполовину.
При посылке любого отличного от 0 значения по адресу 0х200 в приборе происходит его преобразование в тип bool и включается выход.
При посылке 0 выход должен по идее отключиться, но почему-то так и остается..

Сообщения / Posts 43 | Из / From: Россия  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
sa104
Forum Member / Участник форума
Участник № / Member № 5825


Icon 1 отправлено / posted      Профиль для / Profile for sa104           Редактировать/удалить сообщение / Edit/Delete Post 
Все работает. Поставил в проект с примером элемент - выключатель - там он работает.
Где все-таки изменить функции чтения - записи Modbus ?

Сообщения / Posts 43 | Из / From: Россия  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
sa104
Forum Member / Участник форума
Участник № / Member № 5825


Icon 1 отправлено / posted      Профиль для / Profile for sa104           Редактировать/удалить сообщение / Edit/Delete Post 
Пересоздал заново источники и каналы, функции стали ,как в примере, который работает. В атрибутах канала по адресам 0 и 2 в работающем примере появляется 1, либо 0 (вкл./ откл),
а у меня только на 0 адресе кратковременно появляется 1 , затем выключатель на экране отскакивает обратно и снова 0.
По адресу 2 - все время 0. Похоже, проблема где-то здесь..

Сообщения / Posts 43 | Из / From: Россия  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
sa104
Forum Member / Участник форума
Участник № / Member № 5825


Icon 1 отправлено / posted      Профиль для / Profile for sa104           Редактировать/удалить сообщение / Edit/Delete Post 
Все работает. Видимо много раз переделывал проект и где-то накосячил. Создал все заново и результат ОК.
Тему можно закрыть.

Сообщения / Posts 43 | Из / From: Россия  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
   

Послать новую тему / Post New Topic  
Тема закрыта / Topic Closed  Тема закрыта / Topic Closed
Открыть тему / Open Topic   Feature Topic   Переместить топик / Move Topic   Удалить топик / Delete Topic Следующая старая тема / next oldest topic   Следующая новая тема / next newest topic
 - Printer-friendly view of this topic
Перейти к / Hop To


Новости АСУ ТП / News | SCADA / HMI | Обучение / Trainings | Свяжитесь с нами / Contact Us

Rambler's Top100 Rambler's Top100



Powered by Infopop Corporation
UBB.classic™ 6.7.2