Форум TRACE MODE: техническая поддержка   New Poll  
мой профиль / my profile авторизация / login | регистрация / register | поиск / search | часто задаваемые вопросы / faq | начало / forum home

  Следующая старая тема / next oldest topic   Следующая новая тема / next newest topic
» Форум TRACE MODE: техническая поддержка » ТЕХНИЧЕСКАЯ ПОДДЕРЖКА / TECHNICAL SUPPORT TRACE MODE 5 » Редактор Базы Каналов (Математика) / Channel Base Editor » Автопостроение (Страница / Page 1)

  Этот топик включает в себя следующие страницы /
This topic is comprised of pages 1  2 
 
Автор / Author Тема / Topic: Автопостроение
Leon
Active Forum Member / Активный участник форума
Участник № / Member № 624


Icon 5 отправлено / posted      Профиль для / Profile for Leon           Редактировать/удалить сообщение / Edit/Delete Post 
В РПД есть Узел1(контроллер Лагуна) и узел АРМ. В АРМе через автопостроение появился Объект Узел1. В целях отключения некоторых каналов от обмена по M-линку хотелось бы разделить часть каналов по разным объектам (шкаф1 и шкаф2 например). Используя [добавить в объект] я перенес часть каналов в другой объект, но при этом они остались и в старом объекте, почему никак не удаеться их оттуда удалить?
Сообщения / Posts 66 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 2 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Попробуйте выполнить над ними команду "Убрать из объекта". Однако, если Вы выполните команду автопостроения снова - система все равно поместит их опять в этот объект. Вам лучше не обращать на объект созданный автопостроением внимание, а создать два своих объекта и раскидать в них каналы. Пусть будет три объекта - два Ваших, а один, в который будут попадать каналы по автопостроению. На функциональность это никак не влияет.
Сообщения / Posts 15120 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Leon
Active Forum Member / Активный участник форума
Участник № / Member № 624


Icon 1 отправлено / posted      Профиль для / Profile for Leon           Редактировать/удалить сообщение / Edit/Delete Post 
Пробовал [Убрать из объекта] - не помогает, как только переключаюсь на исходный узел, они сразу восстанавливаються в АРМе. Попробовал Ваш вариант с отключением объектов - тоже не работает(судя по возникновению ошибок по M-Link). Если отключаешь один из объектов автопостроения (а их у меня два), то ошибок нет. Видимо объект автопостроения все-таки влияет, но меня такой вариант не устраивает, так как каждый объект автопостроения контролирует два разных устройства и хотелось бы их разделить. Что посоветуете?
Сообщения / Posts 66 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 2 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
А при чем здесь отключение объектов!? [Недоумение / Confused]
Я Вам про него ничего не говорил, я просто предложил не трогать совсем те объекты, которые создаются автопостроением - а каналы из них раскидывать вручную по другим созданным Вами объектам.

Сообщения / Posts 15120 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Leon
Active Forum Member / Активный участник форума
Участник № / Member № 624


Icon 2 отправлено / posted      Профиль для / Profile for Leon           Редактировать/удалить сообщение / Edit/Delete Post 
Я так и сделал. И даже больше - я удалил объекты созданные автопостроением и в ручную раскидал каналы по новым объектам. Вроде работает - системный таймер с отключенного узла не передается,а с работающего узла передается по M-Link, но с небольшой задержкой. Так и должно быть?
Сообщения / Posts 66 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 5 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Что за "системный таймер"?
С какой задержкой?

Сообщения / Posts 15120 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Leon
Active Forum Member / Активный участник форума
Участник № / Member № 624


Icon 2 отправлено / posted      Профиль для / Profile for Leon           Редактировать/удалить сообщение / Edit/Delete Post 
Системный таймер - это канал СИСТЕМНЫЙ с дополнением СЕКУНДЫ. В каждой из двух Лагун я завел по такому каналу и передаю его в АРМ по M-Link. По таблице каналов вижу, что этот канал передается нормально если узел подключен, если узел отключен - таймер не передается. Задержек больше нет, все исправил. У меня вопрос: если нужно отключить не всю лагуну,а только каналы некоторых модулей I-7000, чтобы избавиться от задержек по тайм-аутам (модули отключены от питания) где в этом случае надо отключать запросы к этим каналам? в лагуне или в АРМе, а может и там и там?
Сообщения / Posts 66 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Лучше в Лагуне - ведь она выполняет опрос модулей по ним, если выключить в МРВ, то Лагуне от этого легче не станет. [Улыбка / Smile]
Сообщения / Posts 15120 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Kramarenko Stanislav
Forum Professor / Завсегдатай форума
Участник № / Member № 119


Icon 10 отправлено / posted      Профиль для / Profile for Kramarenko Stanislav           Редактировать/удалить сообщение / Edit/Delete Post 
А можно еще ПОДОБРАТЬ МИНИМАЛЬНЫЕ значения таймаутов, с которыми I-7000 стабильно работают, накинуть для страховки пару-тройку миллисекунд, и тогда отключение модуля практически не будет заметно.
Сообщения / Posts 337 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Kuznetsov
unregistered



Icon 10 отправлено / posted            Редактировать/удалить сообщение / Edit/Delete Post 
to_Leon:

1) Для контроллера: Вы можете выполнить процедуру автопостроения для создания каналов, потом разделить их по вашим объектам. А затем необходимо просто убрать подключаемые модули в закладке "связь по последовательным интерфейсам".

2) для АРМа - вам можно не выполнять процедуру автопостроения, а использовать функцию "Узел"->"Связать с объектом узла". Каналы создадутся один раз и не будут "плодиться" в созданном объекте снова.

IP / IP: IP адрес / IP address | Report this post to a Moderator
Leon
Active Forum Member / Активный участник форума
Участник № / Member № 624


Icon 1 отправлено / posted      Профиль для / Profile for Leon           Редактировать/удалить сообщение / Edit/Delete Post 
Скажите, есть ли принципиальная разница когда узел Master(MPB) запрашивает данные по каналу [In_M-Link] у узла Slave(MPB), или узел Slave(MPB) отправляет данные узлу Master(MPB) по каналу [Out_M-Link]?
Сообщения / Posts 66 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
В принципе - нет.
Сообщения / Posts 15120 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Leon
Active Forum Member / Активный участник форума
Участник № / Member № 624


Icon 1 отправлено / posted      Профиль для / Profile for Leon           Редактировать/удалить сообщение / Edit/Delete Post 
А почему когда назначаю каналу узла Slave тип СВЯЗЬ[Out_M-Link]- узлу Master с типом ПУСТОЙ ничего не передаеться?
Сообщения / Posts 66 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
А флаг для M-Link установлен в разделе Master в настройках узла Slave(МРВ)? [Улыбка / Smile]
Сообщения / Posts 15120 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Leon
Active Forum Member / Активный участник форума
Участник № / Member № 624


Icon 1 отправлено / posted      Профиль для / Profile for Leon           Редактировать/удалить сообщение / Edit/Delete Post 
А почему в разделе Master?, если я спрашиваю возможность запроса данных узлом Slave у узла Master
Сообщения / Posts 66 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Kuznetsov
unregistered



Icon 1 отправлено / posted            Редактировать/удалить сообщение / Edit/Delete Post 
Выдержка из помощи ТМ:
Out M-Link – передача данных удаленному МРВ версии 5.0 по последовательному интерфейсу или по коммутируемым линиям. Данные каналы используются только на узлах со статусом MASTER;

Возможность переключения статуса SLAVE-MASTER доступна только(?) для обмена по коммутируемым линиям. Для этого используется канал "связь -> Шаг модема".

IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Потому что Out_M-Link - это функиця Master.
Только учтите, что по одному и тому же СОМ-порту это не получится, потому как в последовательном интерфейсе не может быть больше 1 Мастера на линии.
Если Вы хотите, чтобы Out_M-Link работал между двумя узлами, то настройка будет следующая:
МРВ1 (Флаги Master и Slave для M-Link)
(СОМ1 - как Master, СОМ2 - как Slave)
МРВ2 (Флаги Master и Slave для M-Link)
(СОМ1 - как Slave, СОМ2 - как Master)

Узлы связаны как МРВ1_СОМ1<->МРВ2_СОМ1 и МРВ1_СОМ2<->МРВ2_СОМ2.

Тогда Out_M-Link/In_M-Link в узле МРВ1 возможен только по СОМ1, а в МРВ2 - только по СОМ2.

Сообщения / Posts 15120 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Leon
Active Forum Member / Активный участник форума
Участник № / Member № 624


Icon 1 отправлено / posted      Профиль для / Profile for Leon           Редактировать/удалить сообщение / Edit/Delete Post 
Хорошо, это понятно. Но у меня такая проблема: Есть три узла:1-узел(Лагуна), 2-АРМ1 (Master),3-АРМ2(Slave).Все три узла сидят на общей шине RS-485. Мне надо чтобы узел АРМ1 считывал данные с узла лагуны и передавал их удаленному АРМу2(Slave) по M-Link. Почему-то на этапе передачи от узла АРМ1(Мастер) узлу АРМ2(Slave)проблемы. Завел канал, который через блок MOVE получает данные с канала, связанного с лагуной и этот же канал настроил на связь по M-Link с узлом AРМ2.И ничего не передается.Причем если делаешь прямую посылку,то все нормально передается,а если через FBD-блок, то ничего не передается.
Сообщения / Posts 66 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Может у Вас FBD-программа просто не обрабатывается?
Сообщения / Posts 15120 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Leon
Active Forum Member / Активный участник форума
Участник № / Member № 624


Icon 1 отправлено / posted      Профиль для / Profile for Leon           Редактировать/удалить сообщение / Edit/Delete Post 
Как только привязываю к каналу [Out M-Link] трансляцию простого FBD-блока с пересылкой, то в этот канал перестает передавать данные в СОМ-порт. Это видно с помощью гипертерминала. Что делать!!!
Сообщения / Posts 66 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Повесьте FBD на канал процедуру Управление отдельного канала подтипа Управление!
Сообщения / Posts 15120 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Leon
Active Forum Member / Активный участник форума
Участник № / Member № 624


Icon 1 отправлено / posted      Профиль для / Profile for Leon           Редактировать/удалить сообщение / Edit/Delete Post 
Пробовал - тоже самое -не работает!
Сообщения / Posts 66 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Давайте проект - посмотрим.
Сообщения / Posts 15120 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
Leon
Active Forum Member / Активный участник форума
Участник № / Member № 624


Icon 1 отправлено / posted      Профиль для / Profile for Leon           Редактировать/удалить сообщение / Edit/Delete Post 
отправлено на hotline1@adastra.ru
Сообщения / Posts 66 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
AdAstra Technical Support
Moderator
Участник № / Member № 4


Icon 1 отправлено / posted      Профиль для / Profile for AdAstra Technical Support           Редактировать/удалить сообщение / Edit/Delete Post 
Привально - и не будет работать. Я же сказал, что на Управление надо повесить программу, а не на Трансляцию. Трансляция необходима для обработки данных с Аппаратного атрибута на Реальное (для каналов типа Input, для Output - наоборот с Реального на Аппаратное). Вы повесили FBD пересылки на канал типа input (timer1234), тем самым Вы его "порвали" пополам - в нем значение со Входа идет на Аппаратное значение, а дальше никуда не идет, потому как Апаратное значение этого канала не связано с Вашей FBD, поэтому на Реальном атрибуте этого канала у Вас всегда ноль. Поэтому и FBD у Вас берет ноль с Реального значения и передает на Реальное канала Outputttt (тип OutPut) - тоже ошибка, потому как должна на Вход передавать. А так у Вас еще и Реальное Outputttt канала забивается нулевым значением атрибута Вход! Поэтому ничего и не работает, когда Вы подключаете программу трансляции значения на закон Трансляции! Внимательней изучите раздел справочной системы "Понятия и определения"-"Канал ТРЕЙС МОУД"-"Обработка данных в канале"-"Обработка данных в канале". Там есть наглядные схемы обработки данных по всем типам каналов. Иначе у Вас в процессе разработки еще могут появиться подобные ошибки.
Сообщения / Posts 15120 | Из / From: Russia  |  IP / IP: IP адрес / IP address | Report this post to a Moderator
  Этот топик включает в себя следующие страницы /
This topic is comprised of pages 1  2 
 

  New Poll   Закрыть тему / Close Topic   Feature Topic   Переместить топик / Move Topic   Удалить топик / Delete Topic Следующая старая тема / next oldest topic   Следующая новая тема / next newest topic
 - Printer-friendly view of this topic
Перейти к / Hop To


Новости АСУ ТП / News | SCADA / HMI | Обучение / Trainings | Свяжитесь с нами / Contact Us

Rambler's Top100 Rambler's Top100



Powered by Infopop Corporation
UBB.classic™ 6.7.2